Firefly Open Source Community

   Login   |   Register   |
12
New Topic

Only splashscreen on ubuntu

5

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
5
Posted at 11/18/2014 13:36:22     
And what does it mean that there is no console? Display manager is working but booting in textmode is not available?
Reply

Use props Report

403

Credits

10

Prestige

12

Contribution

intermediate

Rank: 3Rank: 3

Credits
403
Posted at 11/18/2014 14:21:56     
And what does it mean that there is no console? Display manager is working but booting in textmode is not available?

Yes, you're right. Turning on CONFIG_FRAMEBUFFER_CONSOLE, the kernel keeps on restarting.
Really odd, we are checking at it.

But this has nothing to do with your upgrade. Have you any serial adapter? I wonder your recovery key just not work.

Reply

Use props Report

5

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
5
Posted at 11/18/2014 17:03:15     

I've reinstalled firmware (with reset button). With ubuntu device is not recognized as "adb" like with android. Pushing reset with power shifts device to "loader" without "adb" stage (I've pushed until windows recognizes new usb device).




Now I need to replace display manager (lightdm) with awesome window manager. I know how to start awesmoe with initrc-file but I don't know how to start it in your image. How can I safely remove lightdm and start xserver with awesome at boottime?
Reply

Use props Report

5

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
5
Posted at 11/18/2014 13:07:42     

May be I can boot via sd-card? Where I can find image of "live-sd"? I've tried radxa sdcard image of ubuntu but it is not loaded. I insert sdcard, reboot micro-computer and there is nothing on the screen. I understand that it is radxa not firefly but?I don't find sdcard image at your site.

I've tried a lot of images to boot from sd last 24 hours
Reply

Use props Report

5

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
5
Posted at 11/18/2014 13:04:13     

I've installed driver and androidtool but device is not found. Before installation of ubuntu it works but after that there no device. And windows doesn't tell me that some device is added.

Also if I connect micro-computer via usb to linux computer it doesn't see this connection (I check lsusb and count devices in /dev/)/
Reply

Use props Report

403

Credits

10

Prestige

12

Contribution

intermediate

Rank: 3Rank: 3

Credits
403
Posted at 11/18/2014 09:17:41     

1 Please check the USB cable. Make sure the board is well connected with your host PC during upgrade.

2 The recovery button might need to be pushed and hold hard.




The console does not work at the moment. The framebuffer console in RK3288 SDK kernel is broken.


Reply

Use props Report

5

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
5
Posted at 11/17/2014 19:55:49     

Hello! I am using rk3288 and your image of Ubuntu 14.04. I've installed it like in your tutorial. After that I wanted to turn off autostarting of lightdm and write "manual" word to?/etc/init/lightdm.override.

Now on booting there is only splash screen with "Firefly" word and no actions futher. How can I fix this? How can I fix bootsequence to load console without splash or display manager? Now I cannot flash firmware via androidtool - No Device Found.
Reply

Use props Report

244

Credits

0

Prestige

0

Contribution

intermediate

Rank: 3Rank: 3

Credits
244
Posted at 11/18/2014 02:25:00     
Reply

Use props Report

10

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
10
Posted at 11/18/2014 09:17:16     

Have you install the driver yet? If not ,please install the driver first.

1、Open the AndroidTool.exe .

2、Connect the board via mini USB ,?press the RECOVERY key then power the Firefly.

3、Then you the?AndroidTool.exe ?will show discover a new device and you can download .
Reply

Use props Report

403

Credits

10

Prestige

12

Contribution

intermediate

Rank: 3Rank: 3

Credits
403
Posted at 11/19/2014 11:28:22     

My solution is simple. Do not remove lightdm, but use awesome as the default session:




# cat /etc/lightdm/lightdm.conf.d/20-lubuntu.conf?[SeatDefaults]
autologin-user=firefly
autologin-user-timeout=0
user-session=awesome
Reply

Use props Report

Return to List
12
You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list