Firefly Open Source Community

   Login   |   Register   |
New_Topic
12
New Topic

How to use HDMI audio?

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/22/2016 09:52:02     
The analog audio is working fine, but no matter what I do, I cannot seem to get the HDMI audio to output to my sound system at all.

I used to have this problem with Raspberry Pi, but was able to change something in boot.txt to force it to always emit audio no matter if it can detect that it should or not.  Maybe I need a similar change here?

Can anyone help me to get HDMI audio output working with my firefly?
Reply

Use props Report

1821

Credits

10

Prestige

17

Contribution

super moderator

Rank: 8Rank: 8

Credits
1821
Posted at 8/22/2016 10:24:41     
Hi
  Have you try PulseAudio Volume Control?
Reply

Use props Report

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/23/2016 05:41:51     
@isle yes, I have. It's exactly the same behaviour. My amp doesn't even show the audio LEDs, so I'm pretty confident that the audio mode of the HDMI output is not even being enabled. I need some way to get it to ignore the EDID or similar, I *think*, just like with my Raspberry Pi
Reply

Use props Report

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/23/2016 05:49:34     
How can I change the kernel command line issued by the bootloader? I think that may hold the answer.
Reply

Use props Report

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/23/2016 06:25:33     
Ok, I figured out how to change kernel command line with rkflashtool -- tried adding `hdmi.audio=1` as I had seen for sunxi, but no change, so apparently that is not the parameter name for rockchip (surprise, surprise).

Are there good docs on what arguments the rockchip kernel wants somewhere?
Reply

Use props Report

1821

Credits

10

Prestige

17

Contribution

super moderator

Rank: 8Rank: 8

Credits
1821
Posted at 8/23/2016 10:04:13     
Hi  
  which firmware did you use? or did you make it by yourself ?
Reply

Use props Report

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/24/2016 05:06:45     
@isle I'm using the latest dual-boot firmware image
Reply

Use props Report

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/24/2016 06:23:34     
When I play audio over the RKSPDIFCARD device the light on the optical port comes on, and it goes off again when the audio stops. So *something* is happening. But not hearing anything over HDMI and no lights on my amp to show that it's receiving any audio signal.
Reply

Use props Report

27

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
27
Posted at 8/24/2016 06:40:19     
I just booted to the Android, just to try that. No matter what audio device I pick, sound comes out of the analog port and nothing over HDMI.
Reply

Use props Report

1821

Credits

10

Prestige

17

Contribution

super moderator

Rank: 8Rank: 8

Credits
1821
Posted at 8/24/2016 09:55:12     
Hi
   did the system recognised the HDMI sound card when you insert your sound system?
  what did you get  from "cat /proc/asound/cards"?
Reply

Use props Report

Return to List
12
You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list