Firefly Open Source Community

Download Boot Fail

72

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
72
Posted at 9/26/2017 11:48:42     
Last edited by Fallen In 9/26/2017 11:50 Editor

After downloading a bad bootloader I can not boot into loader mode anymore.

I have booted into maskrom mode but can't flash any bootloader. I am trying to flash MiniBootLoader.bin from Firefly-RK3399_Android7.1.1_170829.

Every time I get "Download Boot Fail".
downloadbootfail.jpg
Reply

Use props Report

119

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
119
Posted at 9/29/2017 08:41:01     
What configs are you using and have you tried a different tool? Every time I compile linux from scratch or try to program something that's not a distribution image I have to short the pads and boot in maskrom to load. If you're okay with the whole android image maybe you could try it in maskrom and see what happens. You're only shorting the pads when you apply power and not continuous right?
Reply

Use props Report

72

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
72
Posted at 9/30/2017 02:04:29     
Last edited by Fallen In 10/23/2017 01:22 Editor

Thank you for your response. I actually solved my problem.

~~TLDR: Use a USB2 linux port.~~ Read next post!

I had to short the pads on the back of the board to get into maskrom mode since loader mode wasn't working (obviously since I broke the bootloader).
I tried flashing the bootloader on windows using FactoryTool and AndroidTool but both returned the same "Download Boot Fail". Even tried reinstalling the drivers to no avail.

Next I tried my linux laptop. Here I always got "Failed to create comm object", no matter which linux tool I used, same result. I found posts online that suggested this was a SELinux error and attempted the solution they provided, but again, no luck/same result.

Finally I had the idea to try a linux machine with a USB2 port since I had read about problems with rkflashkit and USB3 ports. Tried it and it instantly worked just as it was supposed to.
Reply

Use props Report

72

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
72
Posted at yesterday 01:22     
Finally discovered the source of my problem, I have tlp installed so auto suspend USB was enabled. It seems none of the tools support this, you will need to disable auto suspend USB power saving feature on your computer to get it to work.
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list