Firefly Open Source Community

Audio not working on Ubuntu 16.04 (No sound card found)

97

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
97
Posted at 11/9/2017 15:38:31     
Hi,

    I'm using Ubuntu 16.04 and tring audio from command line. It says "no soundcards found"

firefly@firefly:~$ aplay -l
aplay: device_list:268: no soundcards found...
firefly@firefly:~$

Could someone help? What am I missing?

Thanks,
San
Reply

Use props Report

592

Credits

0

Prestige

0

Contribution

advanced

Rank: 4

Credits
592
Posted at 11/10/2017 11:53:47     
Try to update the sdk , the  newest commit have been solved the problem of system no sound  .
Reply

Use props Report

97

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
97
Posted at 11/10/2017 13:30:31     
Thank you. The latest eMMC image that I can find is https://drive.google.com/drive/f ... gAqAX2oyZkg2QVQwZjA and I'm currently using this (which has audio issues)

Could you please point me to the latest Ubuntu image on Google Drive?
Reply

Use props Report

97

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
97
Posted at 11/11/2017 00:34:40     
Last edited by santo4ul In 11/11/2017 00:36 Editor

Hi leung先森,

I compiled the latest kernel and I can see the sound card now. However, when I play a wav file using "aplay file.wav" command, I couldn't hear anything on my headphone.  I tried increasing the gains, but no luck.

Maybe there are some alsa mixer controls needs to be set. Could you please share details on the alsa mixer controls for playback and record?

Thanks,
San
Reply

Use props Report

43

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
43
Posted at 11/16/2017 17:10:55     
hi santo4ul,
     RK3399? if it , you need upgrade this firemware.
   
  1. https://pan.baidu.com/s/1hsOCOJU      Firefly-rk3399_xubuntu1604_201711021305.img
Copy the code

     RK3288? if it ,
     http://dev.t-firefly.com/forum.p ... mp;highlight=es8323   
Reply

Use props Report

97

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
97
Posted at 11/17/2017 13:54:31     
Hi thank you. I'll try.

pan.baidu.com is all in Chinese and i'm finding it difficult to download the file. Could you also please upload the firmware on Google Drive?

Thanks,
San
Reply

Use props Report

43

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
43
Posted at 5 day before     
santo4ul Posted at 11/17/2017 13:54
Hi thank you. I'll try.

pan.baidu.com is all in Chinese and i'm finding it difficult to download  ...

https://drive.google.com/open?id ... 9x9_9Owzy15thfvOfSu
Reply

Use props Report

97

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
97
Posted at 4 day before     
Thank you. I tired audio with the latest image.

Audio works only the first time. 2nd time onwards there is only a small glitch heard and there is no audio.

We've to re-boot the board to make it work again (it works only once)

Thanks,
San
Reply

Use props Report

43

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
43
Posted at 3 day before     
santo4ul Posted at 11/21/2017 19:53
Thank you. I tired audio with the latest image.

Audio works only the first time. 2nd time onward ...

Menu -> Multimedia -> pulseAudio Volume Control -> Configuration

Select sound card which you want to open, turn off another sound card.
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list