Firefly Open Source Community

Compling SDK on Ubunu 16

17

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
17
Posted at 12/4/2017 03:30:51     
Hi
When I am compling the SDK on Ubuntu 16, I am getting this error:
*******************
You are attempting to build with the incorrect version
of java.

Your version is: openjdk version "1.8.0_151" OpenJDK Runtime Environment (build 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12) OpenJDK 64-Bit Server VM (build 25.151-b12, mixed mode).
The required version is: "1.7.x"
*****

I have openjdk-8-jdk on my system. What is the reason of the error?


Reply

Use props Report

663

Credits

0

Prestige

0

Contribution

advanced

Rank: 4

Credits
663
Posted at 12/4/2017 10:23:25     
Reply

Use props Report

17

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
17
Posted at 12/4/2017 21:43:33     
yes
of course. I know it.
But there is no other version of Java on Ubuntu 16.
In other words, there are only two versions of openjdk on Ubuntu 16: 1.8.0 and 1.9.0. Now, is there any way to use these ones? or how can I get Java version 1.7.0 on Ubuntu 16?
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list