Firefly Open Source Community

   Login   |   Register   |

Everything is now broken

80

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
80
Posted at 11/20/2019 23:29:29     
I downloaded the October updates:
Ubuntu fails on apt update. All versions.
Android 8.1 has no network access even with linksys USB wifi dongle.
ROC-RK3399-PC_Industry7.1.2_HDMI_191026 wont boot.

Reply

Use props Report

80

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
80
Posted at 11/24/2019 22:55:11     
last attempt to update last ubuntu release.

firefly@firefly:~$ sudo apt update
Hit:1 http://wiki.t-firefly.com/firefly-rk3399-repo bionic InRelease      
Hit:2 http://ports.ubuntu.com/ubuntu-ports bionic InRelease                    
Hit:3 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease            
Hit:4 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease         
Hit:5 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease           
Hit:6 http://archive.canonical.com/ubuntu bionic InRelease                     
Reading package lists... Done                                                  
Building dependency tree      
Reading state information... Done
251 packages can be upgraded. Run 'apt list --upgradable' to see them.
firefly@firefly:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libgles2 : Depends: libglvnd0 (= 1.0.0-2ubuntu2.2) but 1.0.0-2ubuntu2.3 is installed
libgstreamer-gl1.0-0 : Depends: libgstreamer1.0-0 (>= 1.14.5) but 1.14.4-1firefly1 is installed
libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.26.2-0ubuntu0.18.04.1) but 2.22.5-0ubuntu0.18.04.1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
firefly@firefly:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  gir1.2-gstreamer-1.0 libgles2 libgstreamer1.0-0 libgstreamer1.0-dev
  libjavascriptcoregtk-4.0-18
The following packages will be upgraded:
  gir1.2-gstreamer-1.0 libgles2 libgstreamer1.0-0 libgstreamer1.0-dev
  libjavascriptcoregtk-4.0-18
5 upgraded, 0 newly installed, 0 to remove and 246 not upgraded.
141 not fully installed or removed.
Need to get 0 B/8946 kB of archives.
After this operation, 2132 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 102989 files and directories currently installed.)
Preparing to unpack .../libgles2_1.0.0-2ubuntu2.3_arm64.deb ...
Unpacking libgles2:arm64 (1.0.0-2ubuntu2.3) over (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles2_1.0.0-2ubuntu2.3_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libGLESv2.so.2.0.0', which is also in package rockchip-mali-midgard14 1.6-1
Errors were encountered while processing:
/var/cache/apt/archives/libgles2_1.0.0-2ubuntu2.3_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
firefly@firefly:~$
Reply

Use props Report

1130

Credits

0

Prestige

0

Contribution

vip

Rank: 6Rank: 6

Credits
1130
Posted at 11/27/2019 17:37:06     
We have to lock up the gstreamer version to match the Rockchip upstream modification.

We do not recommend a 'apt-get upgrade' here.
Reply

Use props Report

80

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
80
Posted at 6 day before     
I did get the update to work but gpu still very slow.
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list