Firefly Open Source Community

   Login   |   Register   |
New_Topic

flashing tools

80

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
80
Posted at 4/27/2016 19:34:01     
Last edited by banavathvishnu In 4/27/2016 20:25 Editor

Hi,
My firefly-rk3288 board has broken when I tried to flash a different bootloader and I have recovered it back flashing recovery image. I could see board boots to android.
BUT when I tried to flash kernel Image (kernel-4.0) that I have built. Although flashing tools says flashing completed successfully but I don't see board uses the kernel Image I flashed. It still uses older kernel that was flashed as part of recovery image.

When rkflashkit tool used
------------------------------
sudo rkflashkit flash @kernel kernel.img reboot
Found devices:
0x2207:0x320a

============= 2016-04-27 12:24:08 ============

        Reading flash information
        Loading partition information
        CMDLINE:console=tty0 console=ttyFIQ0 earlyprintk androidboot.hardware=rk30board androidboot.console=ttyFIQ0 board.ap_has_alsa=0 root=/dev/block/mtd/by-name/linuxroot rw rootfstype=ext4 init=/sbin/init initrd=0x62000000,0x00800000 mtdparts=rk29xxnand:0x00002000@0x00002000(uboot),0x00002000@0x00004000(misc),0x00008000@0x00006000(resource),0x00008000@0x0000e000(kernel),0x00010000@0x00016000(boot),0x00010000@0x00026000(recovery),0x0001a000@0x00036000(backup),0x00040000@0x00050000(cache),0x00002000@0x00090000(kpanic),0x00180000@0x00092000(system),0x00002000@0x00212000(metadata),0x00200000@0x00214000(userdata),0x00620000@0x00414000(linuxroot),-@0x00a34000(user)

        Partitions:
        uboot        (0x00002000 @ 0x00002000)    4 MiB
        misc         (0x00002000 @ 0x00004000)    4 MiB
        resource     (0x00008000 @ 0x00006000)   16 MiB
        kernel       (0x00008000 @ 0x0000E000)   16 MiB
        boot         (0x00010000 @ 0x00016000)   32 MiB
        recovery     (0x00010000 @ 0x00026000)   32 MiB
        backup       (0x0001A000 @ 0x00036000)   52 MiB
        cache        (0x00040000 @ 0x00050000)  128 MiB
        kpanic       (0x00002000 @ 0x00090000)    4 MiB
        system       (0x00180000 @ 0x00092000)  768 MiB
        metadata     (0x00002000 @ 0x00212000)    4 MiB
        userdata     (0x00200000 @ 0x00214000) 1024 MiB
        linuxroot    (0x00620000 @ 0x00414000) 3136 MiB
        user         (0x012EB000 @ 0x00A34000) 9686 MiB

        Done!

============= 2016-04-27 12:24:08 ============

        Writing file kernel.img to partition 0x00008000@0x0000E000

        writing flash memory at offset 0x0000E000
        writing flash memory at offset 0x0000F000

        Done!

        Comparing partition 0x00008000@0x0000E000 with file kernel.img

        reading flash memory at offset 0x0000E000
        reading flash memory at offset 0x0000F000

        Done!

============= 2016-04-27 12:24:08 ============

        Rebooting device

        Done!

When upgrade_tool used
----------------------------

upgrade_tool di -k kernel.img
Download kernel start...
Download image ok.

Also tried erasing kernel image and I see the same result

does anyone know what would has gone wrong here? Why does board still uses older kernel image?
Thanks
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list