Firefly Open Source Community

   Login   |   Register   |

Issues with HDMI display resolution







new registration

Rank: 1

Posted at 2/6/2018 21:47:51     

I have an RK-3288 and I'm running into issues getting the correct display resolution over HDMI. It looks like i'm maybe getting 720 or lower, which is then upscaled in my monitor and looks horrible.
If I instead plug in VGA cable it looks good though.

I've tried forcing the HDMI to 1080p but I'm having issues. It looks like xrandr does not properly detect the HDMI port:

sudo xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr: Failed to get size of gamma for output default

sudo xrandr --addmode HDMI-0 1920x1080_60.60
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "HDMI-0"

sudo xrandr --query
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      60.0*
  1920x1080_60.00 (0x6c)  173.0MHz
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock   67.2KHz
        v: height 1080 start 1083 end 1088 total 1120           clock   60.0Hz

I'm using the built in Ubuntu version which was delivered with the device. I've run "apt-get update/upgrade" to download patches.

Additional commands that I've tried:
firefly@firefly:~$ sudo lspci
pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.

firefly@firefly:~$ sudo lshw -C display

firefly@firefly:~$ cat /etc/X11/xorg.conf.d/*
Section "InputClass"
        Identifier "gslX680 evdev touchscreen"
        MatchProduct    "gslX680"
        MatchDevicePath "/dev/input/event*"
        Option "EmulateThirdButton" "true"
        Option "EmulateThirdButtonTimeout" "500"
        Option "EmulateThirdButtonMoveThreshold" "50"
        Driver "evdev"
Section "InputClass"
        Identifier "evdev gsl680"
        #MatchIsTouchscreen "on"
        MatchProduct "gsl680"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"

Thanks for your help


Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list