Firefly Open Source Community

   Login   |   Register   |
New_Topic

[Linux] ROC-RK3588S-PC Ubuntu minimal wireguard support?

50

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
50
Posted at 9/20/2022 01:03:50     
Seems the minimal Ubuntu image doesn't include wireguard. Is it possible to compile a new minimal Ubuntu image with wireguard included? I don't have access to the SDK.

Thanks!
Reply

Use props Report

100

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
100
Posted at 9/20/2022 09:44:43     
WireGuard has been compiled into the kernel.
Reply

Use props Report

50

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
50
Posted at 9/20/2022 22:19:57     
I can't find it in the Ubuntu minimal firmware on the google drive. Can you provide some instructions on how to find it?
Reply

Use props Report

50

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
50
Posted at 9/20/2022 22:30:19     
If you do an "apt install wireguard" it attempts to install the linux-headers-5.4.0-125, linux-headers-5.4.0-125-generic and linux-headers-generic. Then the install fails since the running kernel doesn't match. Using the 5.10.66 headers doesn't work either.
Reply

Use props Report

50

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
50
Posted at 9/26/2022 23:26:13     
Just following up on this. Is anyone able to rebuild the Ubuntu minimal firmware so that a working wireguard install is available?
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list