Firefly Open Source Community

   Login   |   Register   |

Include a more complete development environment?

51

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
51
Posted at 8/3/2019 13:20:55     
2.2GB for an image, and what do I get? GCC.
(pardon my informality)
that is ridiculous.

Once upon a time https://distrowatch.com/table.php?distribution=sorcerer  sorcerer was a small source-based distribution, and it included all the things needed to compile more things, but not muche else, but was 200MB ... 1/10th of the size.


  1. # GDB can be included, even if only gdbserver is actually used.
  2. util-linux-2.34                  
  3. gmp-6.1.2                        
  4. gdb-8.3                          

  5. # Git could be included... for grabbing own projects to apply to the system.
  6. openssl-OpenSSL_1_1_1c           
  7. util-linux-ng                    
  8. libxml2-2.9.9                    
  9. bison-3.4                        
  10. curl-7.65.3                     
  11. git-master                       

  12. # tiny terminal editor
  13. ncurses-6.1                     
  14. readline-8.0                     
  15. nano-4.3                        

  16. # faster make systems
  17. ninja-1.9.0                     
  18. cmake-3.15.1                     

  19. # goes up and down, unlike more
  20. less-530                        

  21. # extra things grabbed, incomplete though, ended up just disabling building docs for nftables.
  22. asciidoc-8.6.9                  
  23. texinfo-6.6                     

  24. # iptables is obsolete/deprecated.  nft allows building muitiple tables of rules for better application-grouped rules.
  25. flex-2.6.4                       
  26. expat-2.2.7
  27. libmnl-1.0.4                     
  28. libnftnl-1.1.3                  
  29. nftables-0.9.1                  

  30. # Things required to compile the kernel.
  31. ed-1.15                          
  32. bc-1.07                          
  33. lz4-1.9.1                        
  34. lzip-1.21                        



  35. # No Node?
  36. node (13.0.0-pre1/12.7.0)                  
  37. npm-cli  
  38. # midnight commander and screen - terminal sharing/overloading utilities
  39. slang-2.3.2                     
  40. mc                              
  41. screen-4.6.2                     


  42. # Any hints on how to apply the binary mali kernel driver?
  43. vulkansdk-1.1.114.0              
  44. mali-fbdev-vulkan               
  45.                                  
  46. # included only because it was part of all added things (optional)                                 
  47. unixODBC-2.3.7                  
Copy the code


it's actually not totally painful to build in a self-hosted environment.
Reply

Use props Report

1034

Credits

0

Prestige

0

Contribution

vip

Rank: 6Rank: 6

Credits
1034
Posted at 8/13/2019 09:50:01     
Hi, d3x0r, are you suggesting to include the packages listed?

With `apt-get`, users are free to install almost anything and can freeze
the root filesystem into an image for later flash upgrade use.
Reply

Use props Report

51

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
51
Posted at 8/14/2019 18:13:25     
apt-get doesn't find anything ever...
i
Reply

Use props Report

1034

Credits

0

Prestige

0

Contribution

vip

Rank: 6Rank: 6

Credits
1034
Posted at 8/15/2019 16:14:39     
Last edited by penguin In 8/15/2019 16:16 Editor

Please try to do a
   sudo apt-get update

first. Then you are free to install the packages with:

   sudo apt-get install PACKAGE

Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list