Firefly Open Source Community

   Login   |   Register   |
New_Topic

mali gpu driver for X11 released!

844

Credits

42

Prestige

48

Contribution

advanced

Rank: 4

Credits
844
Posted at 2/15/2016 14:19:17     
Hi all,

I just noticed that ARM released the mali gpu driver for X11. See: http://malideveloper.arm.com/res ... user-space-drivers/ under topic r6p0-02rel0 for Firefly

You probably also need to compile the corresponding kernel device driver. See: http://malideveloper.arm.com/res ... gpu-kernel-drivers/ withe same release r6p0-02rel0.

So finally GPU support for X11 should be available! Just hope someone can put some effort in to integrating and get this working for firefly!

Cheers -- mac_l1
Reply

Use props Report

844

Credits

42

Prestige

48

Contribution

advanced

Rank: 4

Credits
844
Posted at 2/26/2016 19:10:30     
What needs to be done, as I posted before in http://bbs.t-firefly.com/forum.p ... =697&page=1#pid3499
With this release from ARM the current status is:

1) Kernel mali driver: just checked firefly's lollipop git repo and correct version is already included in lollipop kernel, so should work.
2) User space mali drivers for X11: binary libs made and released by ARM, downloadable. Don't know how linkable they are for what specific linux versions.

Still open, to do: the X11 DRIVERS
3) DRM driver - For X11 support you also need to build rockchip drm kernel driver. Seems there is one included in lollipop kernel of firefly's github (see https://bitbucket.org/T-Firefly/firenow-lollipop/src/95519f45c3214fb3b3547c9fdeca3cb8715d5210/kernel/drivers/gpu/drm/rockchip/?at=Firefly-RK3288),  or another one is provided in mminds github: https://github.com/mmind/linux-r ... vel/somewhat-stable. Tried the first one few months ago and that didnt build then, the latter one is probably made for kernel 4.x. If buildable, this gives some drm.ko file that offers a generic GPU rendering interface needed by X. So some work to be done here.

4) xf86-video-armsoc - You also need a X11 user-space display driver specific for that GPU, and this is provided in mminds github: https://github.com/mmind/xf86-video-armsoc/tree/packaging/debian. X11 server will load this driver to do the accelerated display stuff.

Besides these 4 drivers, maybe some generic X11 components need to be rebuild.
And again, basically, that's all ;-)

Just hope some hero developer is willing to put some effort into this and make it work!
已有 1评分Prestige +10 Money +11 Contribution +12 Pack up reason
psycmos + 10 + 11 + 12

View all ratings

Reply

Use props Report

106

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
106
Posted at 2/15/2016 17:15:19     
Great !

Reply

Use props Report

147

Credits

0

Prestige

0

Contribution

registered members

Rank: 2

Credits
147
Posted at 2/21/2016 22:29:01     
Nice !!

Does anyone managed to use this driver ?

Do you guys know what to put on xorg.conf ?

Should the default firefly kernel support it. ?

Thanks !!
Reply

Use props Report

10

Credits

0

Prestige

0

Contribution

new registration

Rank: 1

Credits
10
Posted at 3/6/2016 10:03:45     
Hi all:
   If RK3288 gpu have gstreamer plugin for hw decode?
Reply

Use props Report

You need to log in before you can reply Login | Register

This forum Credits Rules

Quick Reply Back to top Back to list